YangW

无为,无我,无欲,居下,清虚,自然

仍在使用 VC6 的同学注意了!

前言

VC6,全称 Visual C++ 6.0,诞生于 1998 年,恐怕是目前唯一一款寿命超过 20 岁还仍在大量使用的软件。
因为 VC6 真的太好用了!

但 20 多年造成的科技差距是你必须要知道的。如果你还在用 VC6,请务必读一下本文。

VC6 的问题

1. 对新系统支持差,对调试支持不好

新买的电脑都是 Windows 10 操作系统,VC6 在该系统下,勉强可以通过管理员权限进行调试。但是在调试的时候,如果中断调试,将会造成锁定 exe 无法再次编译的问题,必须重启 VC6 才可以解决。

学习编程时,调试是非常重要的步骤,通常调试的时间会超过代码编写时间的两倍以上,可见调试有多么重要。而“中断调试、再次编译”是非常常见的操作步骤,如果对这个步骤的支持有问题,那会直接影响编程的学习。“不会调试,等于不会编程”,这句话一点也不夸张。

如果用 VC6 是因为电脑配置比较低,那么推荐改用 VC2008 Express 版本,对电脑配置要求同样很低,但是要好用很多。

如果因为其他理由必须要用 VC6,那么推荐安装虚拟机软件(比如 Hyper-V、Virtual Box 等),在虚拟机里面安装 WinXP 系统和 VC6。这样使用 VC6 时功能是完整的。

2. VC6 没有中文版

不要相信任何网上流传的中文版 VC6,微软就没有出过中文版的 VC6,网上那些都是第三方汉化的。汉化 VC6 的过程中需要修改许多东西,导致这些汉化版的 VC6 极不稳定,经常出一些莫名其妙的问题。如果要用 VC6,就用英文原版的。

3. 某些 VC6 的组件不齐全

网上流传的一些 VC6 为了缩小压缩包的体积,精简了许多组件,导致编译的时候可能会产生问题。为此,建议大家到 EasyX 贴吧置顶帖下载吧主整理的 VC6,确保组件齐全。

4. 系统残留的 VC6 注册项有影响

由于原版 VC6 的安装程序并不能在新的操作系统上执行,所以网上的 VC6 大多数是在老系统上安装好,再提取打包制成。

缺少了原版安装程序对安装环境的检测与设置,网上许多 VC6 都无法对一些错误的遗留设置项无法处理,因此有些同学的电脑无论下载哪个 VC6 都无法使用,就是这个原因导致的。

解决办法,同样是到 EasyX 贴吧置顶帖下载吧主整理的 VC6,里面有“修复”脚本,可以非常简单的修复这种问题。

新版本 VC

除此之外,如果你的电脑配置也不错,也没有学校必须用 VC6 的要求,那你真的没有必要使用 VC6,换新版本吧。

新版本 VC 集成在 Visual Studio 里面,简称 VS。所以经常会看到有人说在 VS2017 里面写 C++,其实说的就是集成在 Visual Studio 2017 里面的 VC++。

早期 VC 有对应的 Express 版本,例如 VC2008 Express、VC2010 Express 等,都是免费的,非常适合学习使用。

新的 VS 社区版也是免费的,例如 VS2017 社区版,也非常适合学习使用,只不过对电脑配置要求的高了一些。

分享到

添加评论